Zus Services are disrupted due to AWS Outage

Major incident Applications Zus App EHR Integrations FHIRplace Data APIs Patient History API Package Enrollment API Data Connections CommonWell Network Carequality Network Surescripts Service ADT Networks Quest Connection Intelligent Refresh Data Marts ZusHooks Lenses and Enrichment FHIR APIs athenahealth Elation Health Canvas Medical Healthie
2024-07-30 19:40 EDT · 3 hours, 7 minutes

Updates

Update

AWS has root caused the issue and is currently working on recovery. The Zus App and underlying APIs are functioning again, but data that was being processed during the outage will by delayed in bulk data services. We will be providing updates on the bulk data services here.

July 30, 2024 · 22:52 EDT
Resolved

AWS has root caused the issue and is currently working on recovery. The Zus App and underlying APIs are functioning again.

July 30, 2024 · 22:44 EDT
Update

AWS continues to report increased error rates. As a result:

  • The Zus App and underlying APIs may be unavailable or experiencing increased latency and error rates
  • New records requests may fail, and there may be a delay in inbound data being available to customers. Any jobs queued to run overnight are currently on hold
  • ZusHook delivery may be delayed
  • Data may be arriving in data marts with a delay

We are currently monitoring the situation. AWS expects it to take 2-3 hours to fully resolve. More information about the AWS outage is available here.

July 30, 2024 · 21:18 EDT
Issue

AWS is reporting increased API error rates affecting several AWS services. As a results several Zus services are unavailable or experiencing increased latency and error rates.

July 30, 2024 · 19:40 EDT

← Back