Issue with reciprocity on Carequality and Commonwell Networks

Minor incident Data Connections CommonWell Network Carequality Network
2026-07-29 15:00 EDT · 1 day, 2 hours, 15 minutes

Updates

Resolved

With further research and monitoring, we’ve identified and upgraded the system configuration to improve it’s performance and mitigate the likelihood of further recurrences of the 5xx and latency behavior.

This issue is resolved.

July 30, 2026 · 17:14 EDT
Monitoring

The situation of higher than acceptable 5xx messages and longer latency has resolved, but the team continues to research and monitor.

July 30, 2026 · 09:48 EDT
Issue

We can confirm incident conditions on reciprocity on the CareQuality and Commonwell networks. We are seeing elevated 5xx error rates in our responses to the networks and also latency has increased. The impact is seen on the patient discovery and document list endpoints, document retrieval appears to be unaffected.

The team is continuing to investigate cause and potential solutions.

July 29, 2026 · 15:00 EDT

← Back