Potential issue with Carequality Network

Minor incident Data Connections Carequality Network
2026-07-01 14:33 EDT · 3 weeks, 1 day, 21 hours, 14 minutes

Updates

Resolved

This incident is now resolved. Based on our continued monitoring, record location is performing as expected. We will continue to support customers with reruns as needed.

July 24, 2026 · 11:35 EDT
Monitoring

We have identified an issue that was resulting in slightly degraded patient matching results on the Carequality network since 7/1. The original behavior has been restored as of 7/22. If you have any concerns about a potential data gap, please feel free to rerun a new job or reach out to your account contact.

July 22, 2026 · 18:02 EDT
Issue

We are currently investigating reports of potential issues with Carequality Network. At this time we have not confirmed an incident - our team is actively looking into the situation and will share an update as soon as we know more.

July 21, 2026 · 14:33 EDT

← Back