Documents unable to be loaded in Zus App

Major incident Applications Zus App
2026-07-08 14:20 EDT · 3 hours, 8 minutes

Updates

Resolved

We have discovered and remediated the root cause. Documents are now loading normally. There has been no data loss.

July 8, 2026 · 17:12 EDT
Issue

We are aware the customers are unable to view documents in the Zus App. The team is working on a fix.

July 8, 2026 · 17:11 EDT

← Back