Some UPIDs stuck loading tin Zus App
Minor incident
Applications
Zus App
Data APIs
FHIR APIs
2026-07-07 16:31 EDT
· 1 hour, 47 minutes
Updates
Resolved
July 7, 2026 · 18:15 EDT
We identified the root cause of the stuck UPIDs and deployed a fix. These UPIDs are now loading normally in the Zus App. We will continue monitoring for loading problems.
Issue
July 7, 2026 · 16:31 EDT
We are aware of certain UPIDs stuck in a loading state in the Zus App and are currently working on mitigation.
← Back