Carequality reciprocity services experiencing elevated error rates

Minor incident Data Connections Carequality Network
2026-06-26 15:44 EDT · 18 hours, 46 minutes

Updates

Resolved

This issue was resolved at 11:10pm EDT yesterday evening.

June 27, 2026 · 10:23 EDT
Issue

We are investigating elevated error rates in the Carequality reciprocity service, which responds to inbound queries for patient records from other network participants. As of 5:44 PM ET, the reciprocity service is successfully responding to ~75% of requests.

June 26, 2026 · 21:41 EDT

← Back