GPS Summaries are intermittently failing to generate

Minor incident Applications Zus App
2026-06-05 13:40 EDT · 1 hour, 13 minutes

Updates

Resolved

We’ve resolved the root issue causing some Generated Patient Summaries to never load or error. Previously impacted users should be able to generate summaries, and we will continue to monitor GPS status.

June 5, 2026 · 14:52 EDT
Issue

We are investigating reports of GPS summaries failing to load. We will post an update as soon as we’ve identified the root cause.

June 5, 2026 · 13:40 EDT

← Back