Degraded performance in the Zus App and Zus APIs

Minor incident Applications Zus App EHR Integrations Data APIs FHIR APIs athenahealth Elation Health Canvas Medical Salesforce Health Cloud Healthie
2026-05-07 17:06 EDT · 14 minutes

Updates

Resolved

We identified the root cause of performance degradation and stopped the process from continuing. We’ll continue to monitor closely to ensure there is no further performance impact.

May 7, 2026 · 17:19 EDT
Investigating

We are aware of and investigating degraded performance with Zus APIs and in the Zus Application. We will post an update with more information when we’ve identified the root cause.

May 7, 2026 · 17:06 EDT

← Back