Elevated error rates on the Carequality Network

Minor incident Data Connections Carequality Network
2025-10-15 09:55 EDT · 1 week, 6 days, 22 hours, 47 minutes

Updates

Resolved

We’ve completed re-queries of impacted patients. This incident is now resolved.

October 29, 2025 · 08:43 EDT
Investigating

The re-run of patient queries impacted by the delegation of authority incident continued over the weekend. We anticipate this to be complete by end of day Tuesday.

We will post a final update once this is done.

October 27, 2025 · 10:19 EDT
Monitoring

We believe remaining delegation of authority related issues have been addressed for patient queries to the CareQuality network going forwards.

We are currently in the process of re-running affected queries from the outage period. We will post an expected completion time when one is available.

October 22, 2025 · 17:12 EDT
Monitoring

Response and success rates are returning to normal across all Zus customers. Select Delegate builders onboarded before 5/12/2025 still have configuration issues outstanding on the Carequality network. We are putting short-term remediations in place to allow their jobs to proceed while we work with the network to resolve these issues; we expect to complete this work today.

We expect to start rerunning jobs impacted by the network and AWS incidents tomorrow.

October 21, 2025 · 18:20 EDT
Investigating

We’re currently monitoring intermittently elevated error rates on the CareQuality network that began at around 11 am eastern today.

We will post an update as we have more information, along with an estimate of when we can expect to rerun queries for impacted patients.

October 21, 2025 · 14:30 EDT
Monitoring

We are seeing a return to normal error and success rates for most customers. Certain Delegate customers onboarded before 5/12 are still seeing errors, which we are investigating. We will rerun impacted jobs shortly and will post estimated timelines for those reruns once they become available.

October 21, 2025 · 10:57 EDT
Update

Our Carequality implementer, Kno2, has released a mitigation for the lower response rates seen by Customers with Delegation Notices. The Zus team is reviewing the results.

October 20, 2025 · 12:03 EDT
Update

Customers with Delegation Notices continue to see lower response rates across the network. Kno2, our Carequality implementer, is actively working towards resolution and we will post updates as the situation evolves.

Jobs for non-Delegate customers have stable success and response rates.

October 17, 2025 · 21:03 EDT
Issue

Non-priority jobs are now running on an ongoing basis. We have been monitoring error rates on the Carequality network and have seen stable success and response rates for principal customers over the past 20 hours.

Customers with Delegation Notices are still seeing lower response rates across the network. We are working closely with our Carequality implementer on resolution and will post an update by end of day today.

October 16, 2025 · 12:30 EDT
Issue

We are currently experiencing higher than normal error rates on the Carequality network related to the network’s technical transition to Delegation of Authority.

Customers with a Delegation Notice in place will see lower response rates across the board as the network attempts to correct technical issues. Other customers are experiencing elevated error rates as a knock-on effect.

In response, we have paused the execution of non-high priority jobs. Priority jobs will not be paused but we do expect these jobs to be impacted by the network errors.

While we work to resolve the issue, you may experience delays in the execution of patient history jobs.

We will provide updates to this issue as we continue working with our Carequality implementer and the broader network to resolve.

October 15, 2025 · 09:55 EDT

← Back