Lower match rates on the CareQuality Network

Minor incident Data Connections Carequality Network
2025-09-18 12:15 EDT · 2 weeks, 2 hours, 13 minutes

Updates

Resolved

This incident is now resolved.

Please reach out if you still see unexpected data gaps from this time period

October 2, 2025 · 14:26 EDT
Monitoring

We’ve identified the root cause to be the result of a faulty change to our internal RLS logic. This bug caused a given patient query to target fewer to no organizations for broad non-targeted queries to the CareQuality network. As a result, fewer to no documents were downloaded during broad non-targeted queries for the duration of the incident.

The bug has been reverted, and we are in the process of rerunning the impacted queries.

September 29, 2025 · 14:59 EDT
Investigating

We have been experiencing lower than expected match rates on the CareQuality network since the 18th. This may result in fewer than expected documents for patients with queries performed since the start of this incident.

This is currently under investigation, and we will post an update as we investigate.

September 29, 2025 · 12:15 EDT

← Back