Patient history API and records request statuses incorrectly showing "partially complete"
      
Minor incident
      
        Data APIs
        Patient History API
    
    
      
2025-03-26 12:00 EDT
      
      · 2 days, 6 hours, 3 minutes
    
  Updates
          Resolved
        
        
March 28, 2025 · 18:01 EDT
        
      
      We have corrected records requests that were inaccurately displaying a “partially complete” status. New requests continue to be correctly marked as “completed” when they are done. This incident is now resolved.
          Update
        
        
March 27, 2025 · 19:53 EDT
        
      
      This issue is resolved for new records requests, which will correctly show as completed when they are done. We are working to correct impacted jobs from this week and will have a further update tomorrow.
          Issue
        
        
March 27, 2025 · 15:05 EDT
        
      
  Request statuses are showing “in progress” in the API and “partially complete” in the UI even after jobs have completed. This is impacting all jobs submitted today, and a subset of jobs submitted earlier this week.
We are working on a fix. Please disregard this status in the meantime.
← Back
 Zus Health System Status
            
Zus Health System Status