Slower loading times in the Zus App and EHR integrations

Minor incident Applications Zus App EHR Integrations FHIRplace Data APIs FHIR APIs athenahealth Elation Health Canvas Medical Healthie
2025-03-17 10:09 EDT · 22 minutes

Updates

Resolved

The issue has been resolved.

March 17, 2025 · 10:31 EDT
Issue

We have detected long loading times in the Zus App and EHR integrations, resulting from slower FHIR API performance. We have identified the cause and are implementing a fix as soon as possible.

March 17, 2025 · 10:09 EDT

← Back