Users unable to navigate to additional views in ZAP.

Major incident Applications Zus App EHR Integrations athenahealth Elation Health Canvas Medical Healthie
2025-03-14 11:25 EDT · 49 minutes

Updates

Resolved

This incident is resolved.

March 14, 2025 · 12:14 EDT
Issue

We have identified an issue where ZAP users are unable to navigate away from the Overview. A fix is in progress.

March 14, 2025 · 11:45 EDT

← Back