Delayed medication history requests

Minor incident Data Connections Surescripts Service
2025-01-21 12:00 EST · 6 days, 9 hours, 41 minutes

Updates

Resolved

Data from Surescripts is now processing normally.

January 27, 2025 · 21:39 EST
Monitoring

We’ve identified the root cause and deployed a fix for the issue delaying data delivery on a percentage of medication history requests. We will continue working down the backlog of requests and monitoring system performance over the next twenty-four hours.

January 27, 2025 · 17:46 EST
Investigating

We are currently investigating delays in response time for a percentage of Surescripts medication history refreshes initiated within the last week. We will update shortly as we learn more.

January 27, 2025 · 11:33 EST

← Back