Patient History Job Delay

Minor incident Data APIs Patient History API
2024-10-15 13:02 EDT · 3 hours, 2 minutes

Updates

Resolved

Normal Patient History Job functionality should now be restored; thank you for your patience while we worked to resolve this issue. We will continue to monitor the situation and validate that no remaining concerns remain.

October 15, 2024 · 16:01 EDT
Issue

This morning we found a slow-down of Patient History jobs that is causing a queue of patient history jobs to accumulate. You may experience a delay in availability of your patient records as we work through the backlog of queued jobs. We apologize for the inconvenience and encourage you to reach out to us should you have questions.

October 15, 2024 · 13:02 EDT

← Back