Stalled Patient History Jobs

Minor incident Applications Zus App Data APIs
2024-06-04 11:13 EDT · 2 weeks, 2 days, 23 hours

Updates

Resolved

This issue has been resolved. Jobs that were previously incomplete should have reached completion and you should see a return to normal job functioning. Thank you for your patience!

June 21, 2024 · 10:12 EDT
Monitoring

This incident is resolved going forward. ~45% of jobs run between 5/30/24 and 6/3/24 still show a status of “error”; we expect to have this status updated by tomorrow.

June 17, 2024 · 13:36 EDT
Investigating

We are currently working to resolve the incidences of jobs that errored during the stalled jobs event. We currently estimate that this should be resolved within the next 48 hours and will continue to update you as things progress.

June 11, 2024 · 09:58 EDT
Update

Patient history job functionality has been restored and the queue of in-progress jobs no longer shows evidence of any stalling. Those jobs that errored during the incident period will be re-run. Thank you for your patience and understanding while we resolved this and ask that you contact us should you have any further questions.

June 6, 2024 · 12:51 EDT
Issue

Roughly thirty percent (30%) of patient history jobs initiated on or after May 30th, 2024 are stalled in progress. You may experience delays in the completion of those jobs, see an up-tick in jobs that fail or error, or a slow-down in your ad-hoc queries. Our engineering team is actively remedying each issue. We apologize for any inconvenience this may produce and appreciate your patience as we work to resolve this issue. If you have any immediate concerns, please reach out to our support team.

June 4, 2024 · 11:13 EDT

← Back