Requests to patient history API intermittently failing with HTTP 500 errors

Minor incident Patient History API
2024-04-12 10:00 EDT · 7 hours, 39 minutes

Updates

Resolved

We have implemented a more permanent fix to avoid this set of errors going forward. The patient history API and records request experience is once again fully available.

April 12, 2024 · 17:38 EDT
Issue

Between roughly 10 am and 12:05 pm today, some requests to the patient history API failed with 500 errors. We believe this was due to a large volume of in progress and inbound refresh requests; we are currently scaling to accommodate that load. Although we believe the 500 errors have subsided for now, we’ll leave this incident open until we have a permanent fix.

April 12, 2024 · 12:52 EDT

← Back