Investigating: Patient documents stuck in progress

Minor incident Patient History API
2024-04-05 14:00 EDT · 1 week, 2 hours, 33 minutes

Updates

Resolved

We are happy to say that the refresh system has been running smoothly and our monitoring hasn’t detected any errors. Patient history jobs are continuing to run and are successfully completing on schedule. This means:

  • Normal service to retrieve patient information should be restored.
  • You can trust the system to keep your patient documents current.

We appreciate your patience while we addressed the previous backlog of jobs. Please contact our support team if you have any questions or notice anything unexpected.

In short: Systems are delivering up-to-date patient information.

April 12, 2024 · 16:27 EDT
Update

We’ve successfully cleared the backlog of patient refresh requests and started to update patient information that may have been stalled.

This means:

  • Requests that were partially complete should now start to move to completion as update jobs finish running, providing the most up-to-date patient information.
  • Patients that appeared to be scheduled for a refresh on a past date should have their information updated and their scheduled refresh date updated to a future date.
  • Jobs that were shown as having a status of ‘error’ will also show a status of ‘done’.

In a nutshell: Patient information and documents are starting to flow smoothly and regular service should be restored as the jobs that update patient information finish running.

April 11, 2024 · 17:01 EDT
Update

We are still working on resolving the backlog of refresh requests that were stalled in progress. Users should start seeing requests that were marked “partially complete” yesterday move to completion.

We are also working on clearing a queue of scheduled jobs managed by our intelligent refresh system. Until that queue is clear, users might see patients that appear to be scheduled for a refresh on a past date.

April 9, 2024 · 16:20 EDT
Update

After clearing the queue of jobs, it is performing as expected and the appropriate jobs will be identified and rerun 4/9.

April 8, 2024 · 17:05 EDT
Update

We have established that some documents are being downloaded successfully and becoming available. However, these downloads are progressing at a slower rate than normal; in addition, statuses for the associated jobs are currently stalled in an “in progress” state.

April 8, 2024 · 10:57 EDT
Issue

We have seen that documents coming from the Carequality network have been unsuccessful in their downloads and are stuck in progress. It is estimated that this began in the afternoon of April 5. Users may experience issues viewing data for recent refreshes until this is resolved; job statuses will show a stalled “in progress” state.

We are currently investigating the issue and will provide updates as they become available.

April 8, 2024 · 10:26 EDT

← Back