Resources being created with numerical IDs

Minor incident Zus Aggregated Profile EHR Integrations Patient Data Subscriptions Auth Service ZusHooks
2024-01-22 16:00 EDT · 1 day, 19 hours, 37 minutes

Updates

Resolved

This incident is now resolved, and impacted resources have been corrected.

January 24, 2024 · 11:37 EDT
Update

Resources created by conditional create and update operations are once again getting assigned UUIDs as resource IDs. We are working on correcting impacted resources.

January 23, 2024 · 10:33 EDT
Issue

Since approximately noon Eastern time, resources created by conditional create and update operations are getting assigned numerical resource IDs instead of UUIDs when creating a new resource.

For impacted patient resources, this is causing package enrollments to fail. In addition, ZusHooks are failing to send for all resources assigned numerical IDs. Auth upsert operations which create a new patient or practitioner are also failing.

We are currently remediating this issue and will continue posting updates as they become available.

January 22, 2024 · 16:00 EDT

← Back